読者です 読者をやめる 読者になる 読者になる

かれ4

かれこれ4個目のブログ

HosterをYosemiteで使う

Hoster (RedWinder::MacApp::Hoster) がYosemiteになってInstallできなくなった。

できなくなった原因は、
Contents/distribution.dist
に書かれているVersionチェックの問題。


10.10.x に対して >= '10.4'となっているので、10.10 は10.1扱いで、インストール出来なくなっている。

というわけで、
Contents/distribution.distの7行目のVersionチェックを正規表現でのものに書き換えてあげれば、Yosemiteでも無事にインストール出来る。

-  if(!(my.target.systemVersion.ProductVersion >= '10.4')) {
+  if((my.target.systemVersion.ProductVersion+'').match(/10.[1-3]\./)) {